Video” M10 (replica) driving fail

We recently were made aware of this video from this past summer and thought it was amusing enough to be worth sharing.  We are going to say it’s safe to assume these guys are not doing things properly.

More discussion of this incident over at the Historic Military Vehicle Forum.


  1. Looks like a Sherman chassis to me, but holy sh*t; somebody screwed up somewhere either on the brakes or just plain poor driving!!


  2. Jeeps_Guns_Tanks says:

    If you search around the HMVF forum there is info on this “M10” and it supposedly only has a real Sherman powertrain and suspension, everything else was fabricated or stolen, and does not have a proper motor.


  3. Hi! I am the owner of the “The Armored Patrol” blog which can be found at

    The blog is mainly a WoT/WoWS one, with news and supertest leaks.

    Just wanted to point out that I post historical articles from time to time (now only each weekend because the translator is busy). I would be glad if you would check it out, both in the Historical Articles category and the History tab. Would be honored to be a source for your blog🙂


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: